Guardian Mags - 1911Forum
1911Forum
Advertise Here
Forum   Reviews   Rules   Legal   Site Supporters & Donations   Advertise


Go Back   1911Forum > >

Notices


Reply
 
Thread Tools Display Modes
  #1  
Old 02-24-2020, 04:29 PM
Bowdy74 Bowdy74 is offline
Junior Member
 
Join Date: Jan 2020
Posts: 25
Guardian Mags

I just picked up a used 9mm Guardian!!! I have been wanting one for a long time. It came with three extra mags/ Wilson Combat 500s With base pads. None of them hold the slide open. I checked the factory magazines and they both work fine. Is there anything I can try to get them to work or should I just use them for the range and pick up some Checkmates like the factory ones? I attached a picture, it almost looks like the little tab won’t allow the mag to go far enough in but I don’t know.
Attached Thumbnails
03526F40-C468-4BD3-9D13-1EFE8B016003_1582583339719.jpeg  
Reply With Quote
  #2  
Old 02-25-2020, 09:08 AM
KCJeep KCJeep is offline
Member
 
Join Date: May 2016
Posts: 361
That does look like a base plate fitment issue to me.
__________________
Si vis pacem, para bellum.

"If you want peace, prepare for war."
Reply With Quote
  #3  
Old 02-25-2020, 10:15 AM
Moad Moad is offline
Member
 
Join Date: Apr 2009
Location: The Edge of Glory
Posts: 826
I have the exact same gap using Wilson Combat 500 mags in my 9mm V-Bob and they work fine.

When you insert an empty mag and pull the slide back, does the slide lock back? If not, more than likely your mag followers are not playing nicely with your slide stop. Sounds like the follower is getting above the nub on your slide stop. If the Checkmates work, I would stick with those.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 02-25-2020, 01:28 PM
Bowdy74 Bowdy74 is offline
Junior Member
 
Join Date: Jan 2020
Posts: 25
On all 3 the slide does not lock back.

Quote:
Originally Posted by Moad View Post
I have the exact same gap using Wilson Combat 500 mags in my 9mm V-Bob and they work fine.

When you insert an empty mag and pull the slide back, does the slide lock back? If not, more than likely your mag followers are not playing nicely with your slide stop. Sounds like the follower is getting above the nub on your slide stop. If the Checkmates work, I would stick with those.
Reply With Quote
  #5  
Old 02-25-2020, 02:04 PM
Moad Moad is offline
Member
 
Join Date: Apr 2009
Location: The Edge of Glory
Posts: 826
Bowdy74......I know just enough to be dangerous. With the slide locked back and no mag in the gun, try inserting the mag. Is the bottom lip of the follower below the slide nub or above it.

I assume you have metal followers, correct? Wilson made old ETM's with plastic followers in 9mm.

Only other thing I can think of is changing out the mag springs since you did not buy them new. Old springs will not push that nub up and lock in place.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:50 PM.


NOTICE TO USERS OF THIS SITE: By continuing to use this site, you certify that you have read and agree to abide by the Legal Terms of Use. All information, data, text or other materials ("Content") posted to this site by any users are the sole responsibility of those users. 1911Forum does not guarantee the accuracy, integrity, or quality of such Content.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2015 1911Forum.com, LLC. All Rights Reserved