Forum   Reviews   Rules   Legal   Site Supporters & Donations   Advertise

Go Back   1911Forum > >

Thread Tools Display Modes
Old 12-22-2005, 11:29 AM
CreekIP CreekIP is offline
Join Date: Jul 2004
Location: New Brockton, AL.
Posts: 87
Customer Service!

While at the range yesterday my power extractor broke. Mine is an early modle LTC and has been great till now. I called Para this morning and they said they would send it out today. Can't argue with that!
God Bless America
Reply With Quote
Old 12-22-2005, 01:52 PM
jrpp jrpp is offline
Junior Member
Join Date: Nov 2004
Location: San Juan
Posts: 16
Same thing happend to me. They do work. Good service so far.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 12:06 AM.

NOTICE TO USERS OF THIS SITE: By continuing to use this site, you certify that you have read and agree to abide by the Legal Terms of Use. All information, data, text or other materials ("Content") posted to this site by any users are the sole responsibility of those users. 1911Forum does not guarantee the accuracy, integrity, or quality of such Content.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 2015 1911Forum.com, LLC. All Rights Reserved