1911Forum
Forum   Reviews   Rules   Legal   Site Supporters & Donations   Advertise


Go Back   1911Forum > 1911 Manufacturers > STI/SVI


Reply
 
Thread Tools Display Modes
  #1  
Old 04-25-2012, 08:08 PM
kghof kghof is offline
Member
 
Join Date: Jan 2012
Location: Fort Worth
Posts: 45
Spartan III FTF with supplied mag




Went to the range today with the factory supplied 6 round mag and two 7 round STI mags. I had 2 FTFs, both on the last round from the factory mag. This brings the FTF total to 3 in 1350 rounds, all from the same mag. I've put that mag in the back of the closet. Chalk it up as a bad mag? Weak magazine spring? Any reason to worry about a spring in the pistol? Thanks in advance for any input.
Reply With Quote
  #2  
Old 04-25-2012, 08:52 PM
ekujustice ekujustice is offline
Member
 
Join Date: Dec 2008
Posts: 430
Run all my carry guns with wilson mags and dont have a problem
Reply With Quote
  #3  
Old 04-25-2012, 09:21 PM
polizei1 polizei1 is offline
Member
 
Join Date: Oct 2010
Location: Cinci, OH
Posts: 1,316
Simple solution, if you're only having problems with that specific magazine, don't use it!

I have a Spartan V, I run DP tuned mags, they are great.
__________________
-Cody Meyer
Semper Fi
Rudy Project USPSA Squad (Use Code: Pistol for 25% Off!)
1911 Addicts
Reply With Quote
  #4  
Old 04-27-2012, 01:38 PM
TimT TimT is offline
Member
 
Join Date: Sep 2011
Posts: 144
polizei1, may i ask what is your ammo? Also if re-loads what is the OAL?
I bought five of the DP 10rd mags but still having a problem with the rd thats being loaded nose diving into the empty casing?? This happens one or two times ea mag. The extractor was a little loose but had a GS lock it up, so I'm thinking the rd thats loading is knocking the empty out of the extractors jaw and pushing the empty right back into the barrel? I don't need to say this kills my time... I also put the DP mag well on my Spartan, I would love to NOT leave this gun in the safe on Saturdays. I should also say my comp gun is a Para 18.9 Limited and all of my ammo ara reloads.. So just thinking my OAL for my Para might be my problem?/
Thanks, TimT
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:34 PM.


NOTICE TO USERS OF THIS SITE: By continuing to use this site, you certify that you have read and agree to abide by the Legal Terms of Use. All information, data, text or other materials ("Content") posted to this site by any users are the sole responsibility of those users. 1911Forum does not guarantee the accuracy, integrity, or quality of such Content.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2011 1911Forum.com, LLC. All Rights Reserved