1911Forum
Forum   Reviews   Rules   Legal   Site Supporters & Donations   Advertise


Go Back   1911Forum > 1911 Manufacturers > Rock Island Armory


Reply
 
Thread Tools Display Modes
  #1  
Old 02-23-2010, 11:17 AM
RepeatDefender RepeatDefender is offline
Member
 
Join Date: Feb 2008
Location: Georgia
Posts: 129
RIA Tactical issue?




Hi all! Picked up a new RIA Tactical Saturday morning at the local gunshow. Took it out for a spin on Sunday afternoon. Ran around 8-10 mags through it with only one problem. The first round from the first mag jammed. After that, trouble free with Blazer Brass 230gr FMJ fed from Wilson, Springfield, and ACT-Mags.

However, that's not the problem. The ejected cases are leaving brass marks on the slide, just to the rear of the ejection port, above the flare. It's not a problem, as I see it, as the gun runs fine. But it is displeasing cosmetically.

Am I overly concerned about my pistol's looks or is this an issue?

Thanks in advance for any help!
__________________
Springfield LW Champion Operator
SIG C3+

Last edited by RepeatDefender; 02-23-2010 at 01:43 PM.
Reply With Quote
  #2  
Old 02-23-2010, 01:04 PM
kurmudgon kurmudgon is offline
Member
 
Join Date: Dec 2008
Location: Minnesota
Age: 66
Posts: 1,784
Sounds like the pistol works fine.
Perhaps I'm too far the opposite direction. A few marks or dings mean almost nothing to me.

I think it's part of a mindset that would allow me to use the pistol as a club if needed, without worrying about how it would look with some stains or hair embedded in it.

Regards,
Kur
__________________
more, less, Kur
When I die I'm going straight to Heaven,
'cause I served my time at Coonan Arms.
COFFEE Club member #2
Reply With Quote
  #3  
Old 02-23-2010, 03:56 PM
nailer556 nailer556 is offline
Junior Member
 
Join Date: Jul 2009
Location: Shelby, NC
Posts: 30
Howdy Repeat, I just picked up my RIA Tactical today and didn't seem to have that problem with it. Mine came with Novak mags, don't know if that would have anything to do with it or not but I doubt it. I'm with you though, I wouldn't like it either. I was shooting Magtech ammo, that could have something to do with it. I hope you get it worked out though. Lewt me know if you find out what's up with it. Good luck.
__________________
"SI VIS PACEM PARA BELLUM"
DPMS AR15 M4 style carbine, Para GI Expert 1911, Beretta 92fs 9mm, Remington 870 Tactical 12ga, Ruger 1022 tactical, Century Arms AK47
Reply With Quote
  #4  
Old 02-23-2010, 04:17 PM
timf timf is offline
Member
 
Join Date: Feb 2008
Location: Wytheville Va.
Age: 47
Posts: 237
sounds like a bit of extractor tuning is in order, but i'd put a few hundred rds thru it first after a bit of break in it might fix itself!?
Reply With Quote
  #5  
Old 02-23-2010, 06:11 PM
NIGHT AL NIGHT AL is online now
Senior Member
 
Join Date: Apr 2006
Location: K.C.MO.
Posts: 5,106
Tune the extractor, it's not hard.
Reply With Quote
  #6  
Old 02-23-2010, 10:58 PM
nailer556 nailer556 is offline
Junior Member
 
Join Date: Jul 2009
Location: Shelby, NC
Posts: 30
How would you go about tuning the extracter? I'm kinda new to 1911s, this RIA is my first one, so I don't know much about them yet. I've had problems with my DPMS AR shaving little halve moon pieces of brass too. Anyone know about that?
__________________
"SI VIS PACEM PARA BELLUM"
DPMS AR15 M4 style carbine, Para GI Expert 1911, Beretta 92fs 9mm, Remington 870 Tactical 12ga, Ruger 1022 tactical, Century Arms AK47
Reply With Quote
  #7  
Old 02-24-2010, 05:31 AM
NIGHT AL NIGHT AL is online now
Senior Member
 
Join Date: Apr 2006
Location: K.C.MO.
Posts: 5,106
Quote:
Originally Posted by nailer556 View Post
How would you go about tuning the extracter? I'm kinda new to 1911s, this RIA is my first one, so I don't know much about them yet. I've had problems with my DPMS AR shaving little halve moon pieces of brass too. Anyone know about that?
Go to the M1911. org. home page, then to forum jump,then to technical issues you will find it there.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:23 AM.


NOTICE TO USERS OF THIS SITE: By continuing to use this site, you certify that you have read and agree to abide by the Legal Terms of Use. All information, data, text or other materials ("Content") posted to this site by any users are the sole responsibility of those users. 1911Forum does not guarantee the accuracy, integrity, or quality of such Content.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 2011 1911Forum.com, LLC. All Rights Reserved